All systems operational

Resolved
Login Issues / Error 525

Started
January 31, 2023 at 5:16 PM
Status
Resolved after about 3 hours

Impact

Major outage
Affected
Website
iOS App
  • Resolved
    January 31, 2023 at 8:05 PM

    Thank you for your patience! We just resolved the issue!

  • Identified
    January 31, 2023 at 6:30 PM

    We are continuing to work on a fix for this incident.

  • Identified
    January 31, 2023 at 5:43 PM

    We are continuing to work on a fix for this incident.

  • Investigating
    January 31, 2023 at 5:16 PM

    We are currently investigating this incident.